Can't get the bladeRF to show up in gqrx. Suggestions?

Discussions related to schematic capture, PCB layout, signal integrity, and RF development

Moderator: robert.ghilduta

Post Reply
jsn
Posts: 1
Joined: Sun Jan 26, 2020 12:55 pm

Can't get the bladeRF to show up in gqrx. Suggestions?

Post by jsn » Sun Apr 12, 2020 5:42 pm

Hello!

I'm having an issue getting my bladeRF to show up in the gqrx devices drop down. I took the following actions...

1. Ensured that the FPGA is loaded with firmware
2. Installed all prerequisite software
3. Purged the gqrx configuration file under ~/.config
4. Ensured the device was plugged into a USB 3.0 port
5. My bladeRF shows multiple green lights lit (three in a row, a space, then a fourth light)

Here are my outputs. Any thoughts on the configurations?

Linux host system:

Code: Select all

Linux localhost.localdomain 5.5.15-200.fc31.ppc64le #1 SMP Thu Apr 2 18:48:37 UTC 2020 ppc64le ppc64le ppc64le GNU/Linux
bladeRF detail:

Code: Select all

bladeRF> info

  Board:                    Nuand bladeRF 2.0 (bladerf2)
  Serial #:                 42b32453ed5148bda8a2a369454f5483
  VCTCXO DAC calibration:   0x1f07
  FPGA size:                49 KLE
  FPGA loaded:              yes
  Flash size:               32 Mbit
  USB bus:                  2
  USB address:              6
  USB speed:                SuperSpeed
  Backend:                  libusb
  Instance:                 0

bladeRF> version

  bladeRF-cli version:        1.8.0-git-45521019
  libbladeRF version:         2.2.1-git-45521019

  Firmware version:           2.3.2
  FPGA version:               0.11.0 (configured from SPI flash)
DMESG output:

Code: Select all

[jsn@localhost ~]$ dmesg | grep blade
[    3.439936] usb 2-3.1: Product: bladeRF 2.0
[  430.124963] usb 2-3.1: Product: bladeRF 2.0
[  562.104735] usb 2-3.1: Product: bladeRF 2.0
However, if I even attempt to test using gr-osmosdr derived utilities, such as osmocom_fft, I get the following output...

Code: Select all

gr-osmosdr v0.1.x (0.1.5git) gnuradio 3.7.13.5
built-in source types: file fcd rtl rtl_tcp uhd hackrf rfspace airspy soapy redpitaya 
[INFO] [UHD] linux; GNU C++ version 9.1.1 20190605 (Red Hat 9.1.1-2); Boost_106900; UHD_3.14.1.0

FATAL: No supported devices found to pick from.

Trying to fill up 1 missing channel(s) with null source(s).
This is being done to prevent the application from crashing
due to gnuradio bug #528.

Source has no sample rates (wrong device arguments?).
gqrx device listing:
Image

What am I missing here? Thank you all in advance for your assistance!

Post Reply