Trouble with gnuradio

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
Posts: 2
Joined: Fri Mar 19, 2021 8:20 am

Trouble with gnuradio

Post by spalding »

I have installed bladerf, bladerf-fpga-hostedxa4 using the package manager versions.
I am able to communicate with device using `bladerf-cli -i` and -p, issuing commands and getting reasonable values.
Now I'm trying to install gnuradio in order to be able to see the nuand spectrum .
Following the getting started guide I attempted to compile the gnuradio usingn pybombs.

pybombs prefix init ~/pybombs/bladeRF -a bladeRF -R gnuradio-default

However this failed due to some missing headers (AudioToolboxh) which I installed using gnustep ;
however another missing lib (UHD) still caused a compile fail. I therefore tried using the package manager install of bladerf, bladerf-fpga-hostedxa4, gnuradio and qgrx-sdr and tried the further 'sanity checks', which failed:

Code: Select all

[email protected]:~/uhd/uhd/host/build$ osmocom_siggen -a bladerf=0 -s 2500000 -f 446000000 -g 4 --sine -x 25000
osmocom_siggen: command not found

[email protected]:~/uhd/uhd/host/build$ osmocom_fft -a bladerf=0 -s 2500000 -f 446000000
gr-osmosdr (0.2.0) gnuradio
built-in source types: file fcd rtl rtl_tcp uhd hackrf bladerf rfspace airspy airspyhf soapy redpitaya freesrp 
[bladeRF common] init: DEBUG: entering initialization
[bladeRF source] init: Opening Nuand bladeRF with device identifier string '*:instance=0'
[bladeRF source] Device: Nuand bladeRF 2.0 Serial # ab3d...ca8c FW v2.3.2 FPGA v0.11.0
[bladeRF source] init: Buffers: 512, samples per buffer: 4096, active transfers: 32
[bladeRF source] bladerf_source_c: DEBUG: initialization complete
Traceback (most recent call last):
  File "/usr/bin/osmocom_fft", line 714, in <module>
  File "/usr/bin/osmocom_fft", line 690, in main
    tb = app_top_block(qapp.arguments(), "osmocom Spectrum Browser")
  File "/usr/bin/osmocom_fft", line 301, in __init__
    self.connect((self.src, 0), (self.scope, 0))
  File "/usr/lib/python3/dist-packages/gnuradio/gr/", line 37, in wrapped
    func(self, src, src_port, dst, dst_port)
  File "/usr/lib/python3/dist-packages/gnuradio/gr/", line 100, in connect
TypeError: primitive_connect(): incompatible function arguments. The following argument types are supported:
    1. (self:, block: -> None
    2. (self:, src:, src_port: int, dst:
k, dst_port: int) -> None

Invoked with: < object at 0xffff9959c6f0>, <Swig Object of type 'gr::basic_block_sptr *' at 0xffff995a0270>, 0
, < object at 0xffff9b2373b0>, 0
swig/python detected a memory leak of type 'gr::basic_block_sptr *', no destructor found.
Segmentation fault (core dumped)
Can anyone shed some light?
Post Reply