Installing yate on BladeRF a4 - an unknown error

Discussions related to embedded firmware, driver, and user mode application software development

Moderator: robert.ghilduta

Post Reply
FB11
Posts: 1
Joined: Mon Nov 16, 2020 8:55 am

Installing yate on BladeRF a4 - an unknown error

Post by FB11 »

Hello, I purchased BladeRF mini a4 (v2. 0) with the purpose of installing yate. I am trying to install yate according to the instructions https://hernan.de/blog/creating-a-cellu ... nd-srslte/ and viewtopic.php?f=5&t=5094 everything was installed, but errors appear: https://prnt.sc/vn18ln https://prnt.sc/vn1bsg, tried different versions of FPGA and libblade, the result is the same.
BladeRF mini a4 (v2.0)
The configuration is like this: Ubuntu 18.04
bladeRF-cli version: 1.8.0-git-3a411c87
libbladeRF version: 2.2.1-git-3a411c87
Firmware version: 2.3.2
FPGA version: 0.8.0 (configured by USB host)
What is the problem ? Tell me please ! This topic is open, I am waiting for your help friends.
robert.ghilduta
Posts: 85
Joined: Thu Feb 28, 2013 11:14 pm

Re: Installing yate on BladeRF a4 - an unknown error

Post by robert.ghilduta »

Hello,

Please take a look at latest libbladeRF based Yate and YateBTS RC-2 tarball and instructions at https://www.nuand.com/support/#bts
Ensure libbladeRF is complied from commit hash 3a411c87c2416dc68030d5823d73ebf3f797a145 , and the loaded FPGA version is v0.11.1 .

Please let us know if any issues persist!
Post Reply