Problem with USB in a VM with Linux server hosted on Windows 10

Having issues with the site, hardware, source code, or any other issues?

Moderator: robert.ghilduta

Post Reply
jmglez
Posts: 1
Joined: Fri Feb 02, 2018 4:24 pm

Problem with USB in a VM with Linux server hosted on Windows 10

Post by jmglez » Fri Feb 02, 2018 4:34 pm

Hi guys,

I've just received my bladeRF-x40, very excited about that, but I am having a very frustating issue. This is my setup:

- Hosting machine: Windows 10 pro
- Virtual Machine (with Virtual Box): ubuntu-17.10.1-server-i386 (3GB RAM)

First of all, I had to install the Virtual Box extension pack in order to get the USB3.0 devices recognized. Everything goes well in the linx virtual machine: bladeRF-cli -p command always reports that a device is attached. But as soon as I enter in the interactive model, a problem occure in a few seconds and the device is disconnected. Then, I have to come back to normal mode and connect the usb agai and start over.

Anyone in this forum has noticed this issue? How I can fix it?

Thanks,

JM

PS: by the way, in the windows installation happens exactly the same. The bladeRF CLI utily stop detecting my device after a while.

User avatar
rtucker
Posts: 26
Joined: Sun Jan 25, 2015 10:38 am

Re: Problem with USB in a VM with Linux server hosted on Windows 10

Post by rtucker » Mon Feb 05, 2018 9:50 am

Greetings!

A couple things to check:

- Could you post the output from the "version" command in bladeRF-cli?

- Are you redirecting the USB port each time, or are you using a device filter to redirect persistently (VM settings -> Ports -> USB -> USB Device Filters)?

- Try running bladeRF-cli with "-v verbose" when reproducing the problem... on Linux, you can do

Code: Select all

script -c "bladeRF-cli -v verbose -i"
and it will write the terminal output to a file called "typescript" in the current directory.

- Uninstalling the Windows driver might be worth a try.

- Try booting from the GNU Radio live DVD (https://www.gnuradio.org/blog/using-gnu ... vironment/) or the Ubuntu 17.10 install media in Live mode, instead of Windows... this will remove Windows and VirtualBox from the set of possible problems.

- Also, if your computer has multiple USB 3.0 ports on different controllers, try another one: sometimes xHCI controllers can be troublesome, although they've gotten a lot better in recent years.

Let us know how this goes! Thanks ^^
Rey Tucker (she/her)
Systems Engineer, Nuand LLC
Rochester, NY, USA

Post Reply